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1. Method 

Heuristics, also called guidelines, are general principles or rules of thumb that can guide design 
decisions (Nielsen, 1990). Heuristic evaluation allows you to catch problems that task-oriented 
methods, e.g. cognitive walkthrough, would miss. The procedure is based on the observation that no 
single evaluator will find every problem with an interface, and different evaluators will often find 
different problems. 

Not all problems will be found with this method. It is possible to detect all major problems within an 
interface that are "heuristically identifiable" with 3 to 5 usability experts, but they can catch 75 percent 
of the total heuristically identifiable problems. That is, problems with the interface that actually violate 
one of the ten heuristics (Nielsen, 1994). 

Please note that during the evaluation no users were involved. Some of the issues are merely 
assumptions, but do have some ground based on the heuristics. The issues could be tested for 
correctness by conducting an user-based usability test with the corresponding use cases. 

1.1 Heuristics 

Here are the ten heuristics Nielsen (Nielsen, 1994) comprised from 249 usability problems: 

Visibility of system status 

The system should always keep users informed about what is going on, through appropriate 
feedback within reasonable time.  

Match between system and the real world 

The system should speak the users' language, with words, phrases and concepts familiar to 
the user, rather than system-oriented terms. Follow real-world conventions, making 
information appear in a natural and logical order.  

User control and freedom 

Users often choose system functions by mistake and will need a clearly marked "emergency 
exit" to leave the unwanted state without having to go through an extended dialogue. Support 
undo and redo.  

Consistency and standards 

Users should not have to wonder whether different words, situations, or actions mean the 
same thing. Follow platform conventions.  

Error prevention 

Even better than good error messages is a careful design which prevents a problem from 
occurring in the first place. Either eliminate error-prone conditions or check for them and 
present users with a confirmation option before they commit to the action.  

Recognition rather than recall 

Minimize the user's memory load by making objects, actions, and options visible. The user 
should not have to remember information from one part of the dialogue to another. 
Instructions for use of the system should be visible or easily retrievable whenever appropriate.  

Flexibility and efficiency of use 

Accelerators -- unseen by the novice user -- may often speed up the interaction for the expert 
user such that the system can cater to both inexperienced and experienced users. Allow 
users to tailor frequent actions.  

Aesthetic and minimalist design 

Dialogues should not contain information which is irrelevant or rarely needed. Every extra unit 
of information in a dialogue competes with the relevant units of information and diminishes 
their relative visibility.  
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Help users recognize, diagnose, and recover from errors 

Error messages should be expressed in plain language (no codes), precisely indicate the 
problem, and constructively suggest a solution.  

Help and documentation 

Even though it is better if the system can be used without documentation, it may be necessary 
to provide help and documentation. Any such information should be easy to search, focused 
on the user's task, list concrete steps to be carried out, and not be too large. 

1.2 Test Setting 

The heuristic evaluation was conducted on a PC running Kubuntu Linux 5.10. I have installed KDE 
3.5 and KOffice 1.4.1. I have used the Plastik theme and NuoveXT 1.6.0 icon theme. 

1.3 Usability Test 

For each heuristic, I will address the corresponding problems/flaws I have found. I also have compiled 
a list of guidelines for icons, on which I will judge the usability of the icons and the corresponding 
buttons. Not all problems will be categorized correctly, but I wanted to keep only these ten heuristics, 
to maintain a convenient organization. 

2. Results 

2.1 Visibility of system status 

2.1.1 Splash screen 

Severity: low 

Description: KWord is a light-weight word processing application. This allows users with fast 
computers start the application in just a few seconds. However, users with less modern systems have 
no clear indication that the computer is starting KWord. 

Solution: Show a splash screen while the application is loading. 

Rationale: A widely quoted paper by Robert Miller (Miller, 1968) shows that users will switch to 
another task when there is no response within 10 seconds. When the application gives the user 
feedback – in this case with a splash screen, the user will notice the delay, but has no break in 
thought stream. 

2.1.2 Autospellcheck checks too early 

Severity: medium 

Description: When Autospellcheck is turned on, it will highlight all the incorrect spelled words by 
underlining those words with a red wave line. However, Autospellcheck also highlight words that 
aren’t finished yet. When you are in the middle of typing a word, it already indicates that the word is 
spelled wrong (figure x). 

Solution: Let Autospellcheck check a word for spelling errors, after that particular word has been 
typed completely. 

Rationale: Highlighting incorrect spelled words after they have been typed makes more sense. This 
will remove confusion caused by highlighting early and will also make the interface less bloated. 
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2.2 Match between system and real world 

2.2.1 Frames concept can be ambiguous 

Severity: high 

Description: The frames concept aims to be a semi-professional solution to accommodate users who 
want to have DTP software functionality. However, the goals of these users are different from the 
main users. DTP is aimed at designing, not writing. The users without DTP knowledge are confronted 
with terms that only have meaning for the other user group. Besides, users can get confused when 
they want to create a webpage. 

Solution: Separate writing from designing. Use modes to separate the different interfaces. Introduce a 
design mode. Once activated, the user will only see toolbar with buttons that are relevant to 
designing. Make the presence of this mode felt, so that users that don’t have worked with DTP 
software before, can also try it in a usable manner. 

Rationale: There are two different user groups and therefore it’s also logical to have two different 
interfaces. Designing sounds more task-oriented, instead of object-oriented, which will make more 
sense to the user. Make this design mode discoverable, encourage users to discover this functionality 
by providing visual cues. 

2.2.2 Document structure displays wrong information 

Severity: high 

Description: The document structure view (figure x) shows the structure of the document. However, 
this structure doesn’t match with the user’s mental model. The structure that is shown in the panel, 
has information that isn’t very useful to the user. It contains information about Frames and Framesets, 
but this tree view doesn’t reflect the relationship between the headings and paragraphs for example. It 
has no meaning for the user, so it has no function. 

 

Figure x: Document structure view 
 

Solution: Display a structure that does match with the experience of the user. Show a document 
structure that is meaningful. Microsoft Word does it right (figure x). Also disable the view by default. 
Some users do not need this kind of structure. People who write lengthy documents, such as reports, 
can use this view to have a quick overview of the document. 
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Figure x: A document structure that makes more sense 
 

Rationale: Changing this view provide meaningful information to users and they likely are more eager 
to try this function. 

2.2.2 Ambiguous commands in the Insert menu 
 

Figure x: Insert menu 
 

Severity: low 

Description: There are two commands, Page and Page Break, in the Insert menu that visually do the 
same thing.  

Solution: Get rid of one of the two, preferably Page Break. 

Rationale: Keep the user interface clean by removing two commands that do the same thing. A 
professional user would choose Page Break, and a beginner would probably choose Page. 

2.2.3 Filepath is shown in the titlebar 
 

Figure x: Kword titlebar 
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Severity: low 

Description: The window titlebar shows the full path to the file as well as the filename KWord is 
currently working with (figure x). KDE hides the filesystem structure by using shortcuts such as 
system:///home. Users might not be aware how the filesystem is structured. 

Solution: Show only the document title.  

Rationale: Do not provide information that the user don’t need. The title of the document will suffice. 

2.2.4 Insert menu contains command to insert a file 

Severity: low 

Description: There is a command in the Insert menu called “Insert file…”.  

Solution: Change the text into “Insert document…”. 

Rationale: Speak the user’s language. 

2.2.5 Insert links dialog has wrong text labels for the text boxes 

Severity: medium 

 

 
Figure x:  Figure x:  asfsdafsdfasdf 
 

Description: Via the Insert menu, the user can access the Insert links dialog window (figure x). When 
a user wants to insert a link to an internet address, he has to fill in two text boxes. One that suggest 
the user to type a comment and the other one the URL. Besides internet links, you can also link to e-
mail addresses, links to news (I wonder what that is) and links to files. 

 

Figure x: Insert link dialog in Mozilla Thunderbird 
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Solution: Use text labels that make more sense to the user. Mozilla Thunderbird does it better (figure 
x). Use tooltips to display helpful information instead of showing it directly as Mozilla Thunderbird 
does. This will make the interface less noisy. 

Rationale: Speak the user’s language. 

 
Text view in Konqueror 
 

2.3 User control and freedom 

2.3.1   

2.4 Consistency and standards 

2.4.1 Inconsistency in text labels of tooltips on the Insert toolbar 

Severity: low 

Description: Some tooltips of the buttons on the Insert toolbar end with a period. Some don’t. 

Solution: Be consistent and remove the periods in the tooltips 

Rationale: The tooltips of the buttons on toolbars should have short descriptions and therefore are not 
full sentences. There is no need to end it with a period, so keep the user interface clean. 

2.4.2 Inconsistency in typeface icons on the Format toolbar 

Severity: medium 

Description: The characters in the Bold and Underline icon are in a serif 
font. The Italic and Strike icon are in a sans serif font. 

Solution: Change the typeface of all the characters to serif. 

Rationale: The serif characters will be better distinguishable from sans serif font that is used in the 
interface. It will also be easier to see whether a character is bold. 

2.4.3 Inconsistency in use of looking glass and binoculars icon 

Severity: medium 

Description: Questionable use of a composite metaphor. 

Solution:  

Rationale:  

2.5 Error prevention 

 
Text view in Konqueror 
 

2.6 Recognition rather than recall 

2.6.1 Display modes commands in the View menu don’t have affordance 

Severity: medium 

Description: From the View menu, you can access a submenu called Display modes. From that 
submenu, you can choose from three different types of display modes. However, the names of those 
display modes aren’t suggestive. The user doesn’t know what to expect and has to learn by trial and 



 

Heuristic Evaluation of KWord February,th 2006 Page 9 

 

error to find out which display modes he actually wants to use. 

Solution: Place large icons next to the text labels of the menu items in the Display modes submenu. 

Rationale: Use visual cues to help the user reduce memory load. The user then will be able to 
recognize things instead of remembering and recalling them. 

2.6.2 Show previews in the Style list 

Severity: medium 

Description: The drop down listbox on the Formatting toolbar that allows you to select styles to apply 
on (selected) text, doesn’t have a preview. You have to try it first, to see whether you have the desired 
result. 

Solution: Display a preview of the styles in the Style list. 

Rationale: Reduce the memory load of the user. 

2.6.3  

2.7 Flexibility and efficiency of use 

 

2.8 Aesthetic and minimalist design 

2.8.1 Underline icon suggest also another action 

Severity: medium 

Description: The Underline icon displays a character that is italic and underlined. 

Solution: Don’t make the character look italic. 

Rationale: When the character is both italic and underlined, the user might assume that when he 
clicks on it, the corresponding actions will be executed. 

2.8.2 Strike icon too shiny 

Severity: medium 

Description: The Strike icon is too shiny, which makes it more difficult to easily distinguish 
the character ‘S’. 

Solution: Make the icon look less shiny. 

Rationale: Icons should be easy distinguishable for the user.  

2.8.3 Too much information in subscript and superscript icons 

Severity: medium 

Description: The Subcript and Superscript icons in the Formatting toolbar contain 
extraneous information, specifically the arrows and cursors. 

Solution: Remove the small arrows and cursors in the icons. 

Rationale: Displaying the arrow is unnecessary, because the icon already suggest that the cursor is 
going up. There’s no need to give that information twice. The cursor shouldn’t be showed in that icon, 
because it would mean that you also have to show it in the Bold, Italic etc. icons, which is 
unnecessary. 

2.8.4 Extraneous information in bold, italic and underline icons 

Severity: medium 
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Description: The characters that are placed on top of a button, as if it 
was a key on a keyboard. This has several implications. First of all, 
when you click on the button on the toolbar, the ‘inner’ button isn’t 
pressed. This can be confusing to the user. Second, because of the orange colored border of this 
button (or key), it doesn’t like a real world key. This makes it more difficult to understand what this 
thing actually is. Abiword also places the characters on keys, but does it in a better 
way: it doesn’t have an orange colored border.  

Solution: Make the icons look as simple as possible. Show only the characters to enhance the 
mapping of the icons. 

Rationale: When you provide extraneous information in icons, it will complicate the mapping of the 
icon. This means that it will be more difficult to understand what the button will do. 

2.8.5 Print preview icon doesn’t have much affordance 

Severity: medium 

Description: The Print Preview icon displays a printer with a small lightning strike. The 
lightning strike isn’t a good metaphor for the desired command. 

Solution: Match the user’s mental model. Use an icon that an user has already seen before, for 
example the icon from Microsoft Word. 

Rationale:  

2.8.6 Extraneous information in icons on Insert toolbar 

Severity: medium 

Description: There is extraneous information in the Insert icons on the Insert toolbar. For 
instance the Insert picture icon. Besides an icon of a picture, you can also see a frame. The 
user shouldn’t be confronted with the information that the picture is actually inserted into a 
frame. 

Solution: Remove the frames in those icons. 

Rationale: Provide information that makes sense for the user. 

2.8.7 Unusual placement for document canvas 

Severity: medium 

Description: The (virtual) paper is placed rather odd on the document background. Instead of 
centering the paper, it is aligned to the left with no space between the edge of the background and the 
paper. This makes it more difficult to visually distinguish the size of the paper and also more difficult to 
estimate margins and other white spaces. 

Solution: Centre the paper. 

Rationale:  

2.8.8 Widgets aren’t positioned 
well in the KWord Settings dialog 

Severity: medium 

Description: When the KWord Settings 
dialog is showed at its default size. The 
widgets aren’t aligned well. This is even 
worse when the window is at its minimum 
size.  

Solution: Align the interface elements, so 
the user will be able to easily visually 
distinguish the various items. 
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Rationale: Make use of the Gestalt principle continuity. This improves the visibility of the UI. 

2.8.9  

 

2.9 Help users recognize, diagnose, and recover from errors 

2.9.1 Too much information in the crashed dialog 

Severity: high 

Description:  

Solution:  

Rationale: 

2.9.2 Unavailability of a Help center 

2.10 Help and documentation 

2.10.1 Wrong text label for KWord’s User’s Manual in the Help menu. 

Severity: low 

Description: The menu item KWord Handbook is shown in the Help menu. However, when you click 
on it, a window pops up titled KWord User’s Manual. 

Solution: Change KWord Handbook into something like User Manual. Emphasize the fact that it is 
simply a manual, not a help center or a knowledge base. 

Rationale: Make the command look as unambiguous as possible. The user will be less likely to guess 
what the following action will be then, instead of guessing what It could be (out of the ambiguous 
possibilities).  

 

 
  
 

2.10.2 Availability of Table of Contents 

Severity: high 

Description:  

Solution:  

Rationale:  
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2.10.3 Wrong use of composite metaphor  

Severity: high 

Description: Inconsistency with looking glass icon. 

Solution:  

Rationale:  

 

 
Text view in Konqueror 
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3. Conclusion 

The aim of the study – a heuristic evaluation – was to get a first impression of the usability of KWord. 
It was tested purely based on heuristics, rules of thumb that are applicable to an interface.  

The issues that were found, were in general small and doesn’t require much work to correct. These 
are corrections in things like text labels, tooltips and icons. Most of them can be fixed in time for a 
bugfix release. 

There has to be said that this was not an in-depth evaluation. Certain dialogs that involves complex 
tasks such as Print Preview and the Style Manager require heuristic evaluation and user testing. The 
reason for this is that KWord is largely based on well established word processing software such as 
Microsoft Word and OpenOffice.org. However, there are some details and dialogs that are quite 
different from their  
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